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About Me 

 

My name is Alan and I live in Ipswich, Suffolk in the 

UK. 

I set up Computergaga in 2009 as a resource for 

Microsoft Excel tips and tutorials. 

I am an Excel and Power BI trainer and consultant. I 

have been helping individuals and companies get the 

most from Excel for over 20 years. 

I love it! 

Setting up Computergaga gives me the chance to 

reach more people than I can physically. I am 

honoured to have helped millions of people reach their Excel goals. 

The Computergaga YouTube channel was set up in 2010 to provide free Excel tips and 

tutorials. It has over 650 videos and has had more than 45 million views. 

In 2020, I was awarded MVP by Microsoft in the Office 

Apps & Services category. 

Microsoft Most Valued Professionals are “technology 

experts who passionately share their knowledge with the 

community” and the award is given by Microsoft in recognition of “exceptional community 

leadership”. 

I am very proud to be part of this amazing community. 

Live Meetups 

I organise the monthly London Excel Meetups along with the team at Datel Productions. 

These meetups are FREE and provide a relaxed and enjoyable environment to connect with 

other Excel users. 

Each meetup will have presentations from Excel experts. Come along and boost your Excel 

skills at one of our events. I would love to see you there. 

Why not check out the next events and join us.  

https://www.youtube.com/user/Computergaga?sub_confirmation=1
https://www.youtube.com/user/Computergaga?sub_confirmation=1
https://www.youtube.com/user/Computergaga?sub_confirmation=1
https://www.datelproductions.com/
https://www.meetup.com/London-Excel-Meetup-Group/
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Advanced Excel Formulas 

This best-selling Excel book is jammed packed with more than 500 

formula examples over 846 pages. 

The book is rated 4.9/5 stars and comes with download files to follow 

along with all examples. 

What Will You Learn 

• Gain intimate knowledge of Excel formulas. 

• Understand efficient and practical use of Defined Names and Tables. 

• Master the most popular functions of Excel – VLOOKUP, COUNTIFS, 

MATCH, SUMPRODUCT, and so much more. 

• Learn to return multiple results from a single formula with the magical 

array formulas. 

• Know the best lookup functions for dynamic spreadsheets. 

• Know true power of classic Excel functions such as IF, SUM, and INDEX. 

• Use new Excel functions including XLOOKUP, VSTACK, LET, and 

LAMBDA 

 

Pick up your copy 

https://www.udemy.com/excel-formulas-made-easy/?couponCode=ExcelFormulasComputergaga
https://www.udemy.com/excel-formulas-made-easy/?couponCode=ExcelFormulasComputergaga
https://amzn.to/3Ns2NBC
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Shortcuts 

1. Double Click for a Quick AutoFill 

The AutoFill technique is used to copy formulas, date sequences and Custom Lists amongst 

many others. It’s a brilliant tool that greatly improves data entry and the copying of formulas. 

A great trick is the ability to fill a formula down a column super-fast by double clicking on the 

AutoFill handle. This will only work for filling down columns, and if the column to the left has 

content. 

 

2. Fill Cell Content from Above 

When entering data into Excel, the Ctrl + D keyboard shortcut can be used to fill down. 

The Ctrl + D shortcut will repeat the content and format of the cell above. I heavily rely on 

this shortcut as often the next row uses the same date, name, or category as the previous 

row. This saves time and improves accuracy. 

The great thing about Ctrl + D is that it copies the cell’s formatting as well as its content. 

There is also the Ctrl + ‘ shortcut which only copies the content from the cell above. 

3. Navigate with the Name Box 

The Name Box to the left of the Formula Bar can be used to navigate an Excel spreadsheet.  

It is great for quickly jumping to a specific named area or cell address. 

Click inside the Name Box, type the cell address you want to go to, and press Enter. Or use 

the list arrow and click the defined name you want to go to. 
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4. Switch Between Sheets Quickly 

To quickly switch between the sheets of a workbook use the Ctrl + Page Up (move left) and 

Ctrl + Page Down (move right) keyboard shortcuts.  Using these shortcuts saves having to 

click on the little tabs at the bottom of the book each time. 

Another technique is to right-click in the area where the arrows are to the left of the first 

sheet. This pops up the Activate window to select a sheet from the list. 

 

Finally, you can also use the Navigation pane which is found on the View tab. This can be 

used to quickly navigate to the different used ranges, tables, names, charts, and sheets of a 

workbook. 

5. Quickly Enter Today’s Date 

Never have to check the calendar or type those pesky forward slashes again when entering 

today’s date, as the Ctrl + ; shortcut is there to do it for you. 

6. Select the Current Region 

One of the most beautiful keyboard shortcuts in Excel must be Ctrl + Shift + 8. This shortcut 

will select your current region.  This means it selects all the cells in the range that you are 

currently within. 

Selecting hundreds and thousands of cells just became easy. 

https://youtube.com/shorts/52Nmfyet5Ok


 

  
 

8 Computergaga 

7. Format Cells, Please 

Format Cells is the most important dialog box in Excel.  There you go, I said it.  It’s more 

commonly used than Page Setup, Conditional Formatting, or Data Validation. And because 

of this, the keyboard shortcut should be known and used. 

Its Ctrl + 1. 

8. The Magical Ctrl + Enter Shortcut 

The Ctrl + Enter shortcut is very useful for three main reasons. 

• Confirm the entry or edit of a cell value while remaining on that cell (pressing Enter 

moves you to the cell below or next logical cell, by default). 

• Write formulas to multiple cells (including non-adjacent cells) at once. 

• Fill empty cells in a used range. This is similar to the previous reason, but you can 

enter values too. Great for replacing blank cells with zero or another value. 

In the following image, the SUMIFS function is being applied to four cells at once. They are 

also non-adjacent, and this is not possible to do without Ctrl + Enter. 

Notice that the active cell is D6. This is noted by the cell address in the Name Box. It is 

important to ensure your references are correct (i.e., relative and absolute). 

 

 

  

https://youtu.be/b3pZWMySED4
https://www.computergaga.com/excel/functions/sumifs-function-in-excel/
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9. Copy Formatting to other Cells EASILY 

A common task in Excel is to copy formatting from one cell to another.  It could be that you 

want to copy the specific shade of colour you used to fill another cell, a custom number 

format or some conditional formatting rules. 

The Format Painter is a fantastic tool that will enable you to do all the above easily. 

1. Select the cell that contains the formatting you want to use. 

2. Click the Format Painter button on the Home tab. 

3. Select the cell(s) you want to apply the formatting to. 

The following image shows the Format Painter about to be applied to cell C1. The paintbrush 

icon indicates that I have formatting copied and ready to be applied on-click. 

 

Pro tip: Double click the Format Painter button to keep it on so that you can paint the 

formatting to multiple ranges.  Just remember to click the Format Painter button again when 

you are finished to turn it off. 
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Formatting 

10. Wrap Text 

If you are using a column in your Excel spreadsheet to store a description, comments, or 

large header text, you need to know how to wrap text.  

Wrap text will display the content on multiple lines within a cell to make it visible no matter 

how much you type. 

1. Select the cell(s) that you want to apply wrap text to. 

2. Click the Home tab on the Ribbon and then the Wrap Text button in the Alignment 

group. 

 

In the following image, Wrap Text has been used on some of the headers to wrap text on 

multiple lines within a single cell. 

 

11. Clear Cells Completely 

Pressing the Delete key in Excel only removes the content of a cell (this includes the value 

and formula).  It will not remove any formatting, Data Validation rules, comments, or 

hyperlinks. 

If a cell is not properly cleared it can cause problems in the future by formatting cells 

incorrectly or preventing data being entered due to validation rules. 

1. Click the Clear button in the Editing group of the Home tab. 
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2. Select the option you want from the list. 

12. Show the Day of the Week 

The date can be formatted to show the day of the week in a cell. This is not one of the date 

formats provided by Excel, so it must be created as a custom number format. 

1. Select the cell(s) you want to format. 

2. Click the Home tab on the Ribbon. 

3. Click the Number Format list arrow in the Number group and select More Number 

Formats (or press Ctrl 1.) 

4. Select Custom from the Category: list. 

5. Enter dddd in the Type: box (use ddd for the short name for the day of the week.) 

6. Click OK. 
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Many more date formats can be created using this technique, such as a combination of the 

day of the week and date e.g., Wed, 09 Mar 2023, or a year-month format e.g., 2023-Mar. 

If this is interesting to you, check out the TEXT function in Excel. This formula can be used 

to apply number formats in a formula. Really great for summary text on reports or chart 

labels. 
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13. Check if a Date Occurs This Month 

The Conditional Formatting tool can be used to bring your attention to almost anything you 

want to monitor in an Excel spreadsheet. 

To be notified if a date occurs this month: 

1. Select the range of cells containing the dates that you want to monitor. 

2. Click the Home tab of the Ribbon. 

3. Click Conditional Formatting > Highlight Cell Rules > A Date Occurring. 

 

4. Click on the drop list arrow and select This Month. 

5. Choose a format from the second list or create your own. 

6. Click OK. 
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14. Tracking Due Dates That Have Passed 

You may need to be made aware of dates that have passed on a spreadsheet such as the 

expiry date of a contract, or the due date of a payment. 

By using the TODAY function within a Conditional Formatting rule, it is possible to format 

the cells that contain dates in the past. This makes it easy to identify them on a spreadsheet. 

1. Select the cells that contain the dates you want to format. 

2. Click Conditional Formatting > Highlight Cells Rules > Less Than. 

3. In the box provided, enter =TODAY(). 

4. Choose a format, or create your own, from the list provided. 

5. Click OK. 

 

  

https://www.computergaga.com/blog/essential-conditional-formatting-tricks/
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Formulas 

15. TODAY() and NOW() 

The TODAY and NOW functions are used to calculate the current date. This is extremely 

useful as by finding the current date you can calculate how long it has been since a specific 

date, or how long until an important due date. 

The TODAY function returns today’s date, and the NOW function returns today’s date and 

the current time. 

These functions require no arguments and can be entered into a cell as below. 

=TODAY() 

=NOW() 

The following example can be used to return the number of days until a due date (cell A2). 

=A2-TODAY() 

16. Calculate Age 

There are a few methods to calculate age in Excel, either from a date of birth or between 

two other given dates. 

The following formula can be used to calculate age from a date of birth. 

=TRUNC(YEARFRAC(C3,TODAY(),1)) 

 

https://www.computergaga.com/blog/how-to-calculate-age-in-excel/
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17. Combine or Compare Values with XLOOKUP  

XLOOKUP is the primary lookup function in Excel. It is used to match values in two different 

tables and return a corresponding value. 

For example, XLOOKUP can be used to reconcile invoice payments. It can match an 

‘Invoice ID’ in a ‘payments received’ table to the same ‘Invoice ID’ in an ‘invoices sent’ table 

and return the corresponding payments received value (if there is one). This can then be 

compared to the payment value requested in the invoice. 

The XLOOKUP function is also used to combine values from multiple tables to a single 

table. Normally with the goal of producing a PivotTable for data analysis and reporting.   

XLOOKUP requires 3 pieces of information (arguments), which are detailed below, and also 

3 optional arguments.  

=XLOOKUP(lookup_value, lookup_array, return_array, [if_not_found], [match_mode], 

[search_mode]) 

• Lookup value: The value you are looking for. 

• Lookup array: The range or array in that you are looking for the lookup value. This 

can be a column or a row. 

• Return array: The range or array that contains the value or range to return. 

Let’s see an example of XLOOKUP retrieving matching values from another table. 

In the following image we have a table named tblCodes that lists country names and their 

three-digit country code. 

 

https://www.computergaga.com/xlookup-function-in-excel/
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The following XLOOKUP function is used to look up and return the corresponding country 

code from tblCodes to a customers table. 

=XLOOKUP([@Country],tblCodes[Country],tblCodes[Code]) 

 
 

The XLOOKUP function is one of the most used and powerful functions in Excel. 

See more examples of the XLOOKUP function. 

  

https://youtu.be/sTj3KnbGFhM
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18. Remove Erroneous Spaces from a Cell 

If a cell contains excess spaces at the beginning or end of the cell value it can produce 

wrong results in your formulas, PivotTables, and charts.  

Spaces are recognised as a text character by Excel, so “John” without a space and “John  “ 

with a space on the end are not the same value. 

To remove unnecessary spaces from a cell, you can use the TRIM function. This will not 

only remove unnecessary leading and trailing spaces, but also any extra spaces between 

words. 

The following formula is used to remove any spaces that occur before or after the values in 

the ‘Name’ column. They are then converted to proper case with the PROPER function. 

=PROPER(TRIM([@Name])) 

  

https://www.computergaga.com/excel/functions/proper-function/
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19. Quick Analysis Totals 

The Quick Analysis button in Excel can be used to produce total rows and columns quickly, 

and without needing to know the formulas yourself.  

To see an example, let’s create an often-requested formula – the percentage of total 
formula. 

1. Select the range of cells from which to calculate the total. 
2. Click the Quick Analysis button in the bottom corner of the selected range. 
3. Click the Totals menu item. 
4. Scroll to the right to find the column totals (yellow ones) and click % Total. 
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20. The Awesome IF Function 

The IF function is a logical function that tests a condition and takes a different course of 

action depending on the result of the test.  For example, it may test if a salesperson has met 

their sales target and calculate a bonus if they have but display 0 if they have not. 

The IF function is a key function behind many powerful automated spreadsheets. It enables 

Excel to make decisions on your behalf and perform calculations or change cell values 

automatically. 

The IF function requires three items of information: 

=IF(logical_test, [value_if_true], [value_if_false]) 

Logical test: is the condition that you want to test. 

Value if true: is the action you want to take if the condition is met. 

Value if false: is the action you want to take if the condition is not met. 

In this example, the IF function is used to test if the value in cell B2 is greater than or equal 

to 1,000.  If it is, then it will calculate 15% of the value in cell B2, and if not, it will display 0. 

=IF(B2>=1000,B2*0.15,0) 

 

  

https://www.computergaga.com/excel/functions/excel-if-function/
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21. Create a Top N Report 

With dynamic array formulas and the TAKE function, creating a simple dynamic top N list 

is very easy. 

In this example, a top 5 report has been created from the data in the tblSales table. The N 

value (5 in this instance) is specified in cell F2. If this value is changed (to 10 for instance), 

the report will dynamic adjust. 

=TAKE(SORT(tblSales,2,-1),F2) 

 

For this report, the SORT function orders the data in tblSales in descending order using the 

second column (Value). The TAKE function then extracts the first N rows (amount specified 

in cell F2) only.  

https://www.computergaga.com/blog/what-you-need-to-know-about-dynamic-array-formulas-in-excel/
https://www.computergaga.com/excel/functions/excel-sort-function-sort-data-with-a-formula/
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22. Distinct Count Formula 

There are numerous count functions in Excel, including COUNT, COUNTA, COUNTIFS, and 

COUNTBLANK to name a few. However, there is not one to count the distinct values only. 

Fortunately, there is a UNIQUE function which can be used to return a distinct or unique list 

of values. And from these returned values we can count how many there are. 

The following formula uses the ROWS function along with UNIQUE to return how many 

distinct rows (webinar titles) there are in the Webinar column of the tblData table. 

=ROWS(UNIQUE(tblData[Webinar])) 

 

You can see that there is a count of 9 webinar titles, and 5 distinct titles (how many there are 

when duplicates are removed).  
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Excel Tools 

23. Flash Fill for Fast Data Manipulation 

One of the most impressive tools in Excel is Flash Fill. This feature always gets a ‘wow’ from 

attendees of my Excel training when they’re seeing it for the first time. 

Flash Fill is a tool that predicts a pattern in our data and fills the results down a column. So, 

we provide the results to what we want to achieve, and if a pattern is detected, Flash Fill 

completes the rest. 

Take this example, we have references that are made up of three parts and delimited by the 

slash “/”. We want to extract the characters between the two slashes (the second part). 

By entering the first result and then beginning to enter the second result, Flash Fill 

automatically appears offering to finish the data entry for us. It has successfully picked up 

the pattern of characters between the two slashes. 

 

Press Enter to let Flash Fill complete the process. 

There are other methods to run a Flash Fill in Excel. These include clicking the Flash Fill 

button on the Data tab of the Ribbon, and pressing Ctrl + E. 

Another way though, is to drag the fill handle down (as indicated in the first tip in the book) 

from the first result cell, click the Auto Fill options tag, and click Flash Fill. 
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How awesome is that? 

There are many great data manipulations and transformations that Flash Fill can assist with, 

including joining cell values together, changing case, converting values.  
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24. Stop Excel from Removing Leading Zeroes 

You have probably entered a number into Excel before that begins with a zero, such as a 

phone number, zip code, or an ID number. And then the frustration when Excel automatically 

removes it. 

There are few solutions to stopping this from happening, the main one is to format the range 

as text before you type the number. 

However, there is also an option to disable this behaviour. 

1. Click File > Options > Data. 

2. Uncheck the first checkbox in the Automatic Data Conversion section for Remove 

leading zeros and convert to a number. 

 

The error checking rule for a number being displayed as text will still be shown by Excel. 

This can and should be removed by selecting the range, clicking the green triangle, and 

clicking Ignore Error.  
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This is an application-level setting so will be applied to all workbooks unless you enable it 

again. 
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25. Use Custom Lists 

Excel has a feature called Custom Lists to store lists of data to be used for custom sort 

orders and fill sequences.  Excel comes with four custom lists already created for your use. 

These include long and short versions of the months of the year, and long and short versions 

of the days of the week. 

So, if you have ever wondered, how does Excel know which order the names of months 

should go in? 

The answer is because of its Custom Lists. 

You can create your own custom lists.  For example, you may want to sort month names in 

an order outside of the Jan-Dec order, such as financial years that may start from April and 

finish in March, for instance. 

In this example, we will create a custom list for order competency levels for Excel training. 

These should go in the order of Beginners, Intermediate, Advanced, and then Expert. And 

not in A-Z order as Excel would do unless specified. 

1. Click File > Options. 

2. Click the Advanced category and scroll all the way to the bottom and click Edit 

Custom Lists. 

3. Enter the items to use in the list in the List entries box or click in the Import list 

from cells box, select a range of cells on a sheet that includes the list items, and 

click Import. 

 

https://www.computergaga.com/blog/custom-sort-in-excel/
https://www.computergaga.com/blog/custom-sort-in-excel/
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4. Click Add to add the custom list and then click OK. 

This list can then be used when sorting a table. You will find it in the custom sort settings, as 

shown below. 
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26. Copy Column Widths Only 

A feature in Excel named Paste Special enables you to paste only specific element of a 

copied value and/or perform other special operations. 

For example, you can use Paste Special to: 

• Paste value only. 

• Link to the copied cell. 

• Perform mathematical operations on paste. 

• Paste validation rules only. 

• and more. 

It is not a rare question for someone to ask me if it is possible to quickly make one column to 

exact same width as another. And yes of course, we can copy that.  

1. Select a cell in the column with the width that you want repeated. 

2. Press Ctrl + C to copy. 

3. Select a cell(s) in the column to change and click Home > Paste drop-down arrow > 

Paste Special. 

4. Click Column widths and click OK. 
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27. Convert Unrecognised Dates 

There are regionals settings applied to your Excel application that are taken from Windows 

(or other operating system) by default. So, for me, my regional settings are for the UK. 

These settings control a few aspects of how Excel behaves, one of them is its ability to 

recognise data on input. For example, the structure of dates and the decimal separator used 

in numbers. 

In the image below, I have dates that are in a month/day/year (MDY) format. Due to my UK 

settings, Excel is expecting a DMY format and is therefore confused by this data and does 

not store it correctly. 

 

This can cause trouble, as I cannot analyse this data effectively or perform calculations 

using those dates if they are not recognised. 

In Excel, there are a few methods for converting data types, such as these dates. The 

quickest method is using Text to Columns. 

1. Select the range of cells containing the dates. 

2. Click the Data > Text to Columns. 

3. Click Next to skip the first two steps of the wizard. 

4. At step 3, click the Date option and choose the date format to convert from the list. In 

this instance, the data is in the MDY format. 

5. Click Finish. 

https://youtu.be/xYsCjlzjesQ
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The dates are now converted into the local DMY format and can be used for all your 

favourite Excel formulas or commands. 
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28. Use Goal Seek to Help Predict Values 

Goal Seek is one of the what-if analysis features in Excel that enable you to determine the 

impact of a change in a value.  

What Goal Seek does is it finds the input value needed to achieve a specific target value in a 

formula. 

In this example, we have the following data that calculates the payments on a loan. We 

know the fixed interest rate (cell B2), the term (cell B3), and the payments we can make (cell 

B5). 

In cell B5, the following formula is used to calculate the monthly payments based on the 

information from range B2:B4. 

=-PMT(B2/12,B3*12,B4) 

 

The goal is to find out the loan amount that we can borrow based on the amount that we 

know we can afford to pay each month (let’s make this 450). 

1. Click on the cell that contains the value you want to change (this must contain a 

formula). This is cell B5 in this instance. 

2. Click Data> What-If Analysis > Goal Seek. 

3. The Set cell is already established. Enter 450 for the To value and use cell B4 for 

By changing cell. 

4. Click OK. 
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Goal Seek has found a solution. The loan amount we can afford based on those monthly 

payments, and the other fixed term and interest rate parameters, is 19,637. 

Click OK to keep the solution or click Cancel to return to the previous values. 
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29. Create a Drop-Down List of Options 

Validate and speed up data entry with a drop-down list. It works brilliantly when the user has 

a selection of options to choose from such as male or female, or a list of 5 colours. 

The easiest way to create a drop-down list is to use the Data Validation tool. 

1. Select the cells you want to apply the drop-down list to. 

2. Click Data > Data Validation. 

3. Click the Allow: list arrow and select List.  

 

4. Click in the Source: box and type the items you want to use in the list separated by a 

comma or select a range of cells on a sheet that contains the items. 

5. Click OK. 

The list will appear as you click the cell containing it and will only accept items from this list. 
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30. Convert a Range to a Table 

When working with lists of data in Excel, converting them to a Table will provide increased 

functionality, and is highly recommended. 

Now, not everything in Excel is, or should be, a Table. But any list resembling a Table, 

should be so. 

Why use Tables? 

Tables in Excel provide many benefits. These include: 

• They provide a dynamic data set that will expand and collapse as rows and column 

are added or removed. This ensures a dynamic source for your charts, formulas, 

PivotTables, formatting, etc. 

• They provide a meaningful reference for use anywhere in the workbook. Check out 

the nice drop-down list of Table elements offered by a Table when writing the SUM 

function below. No selecting sheet columns or large ranges needed.   

 

• You can use Slicers for a modern filtering option. These are brilliant for creating 

gorgeous interactive dashboards. 

• Tables can be used in BI tools such as Power Query and Power Pivot. 

• And much more beyond the scope of this tips book. 

So how do you create one? 

1. Click any cell in the range that you wish to convert. 

2. Click Insert > Table or press Ctrl + T. 

3. Check the data range offered in the dialog (as shown below) and if your range 

currently has headers. And click OK. 
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4. You must then give your Table a name. Do this by entering a name in the Table 

Name box on the Table Design tab of the Ribbon. 

Tables have been used for a few of the examples in the previous formulas section of this 

book. So, if you were wondering what references such as [@Customer] and 

tblData[Webinar] were, they are table references. 

When referencing cells and column within Tables, you still must bear in mind the concept of 

relative and absolute references. This video will explain how to make table references in 

formulas absolute.  

https://youtu.be/JjYbuHa1YYQ
https://youtu.be/JjYbuHa1YYQ
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31. Use Sparklines for In Cell Micro-Charts 

Sparklines are a feature introduced in Excel that enable you to create simple in cell micro-

charts.  They do not provide much detail due to their size, but they do offer a fantastic visual 

representation of data for at-a-glance comparisons and progress checks. 

To insert a Sparkline; 

1. Select the cell(s) where you want the Sparkline(s) to appear. 

2. Click the Insert tab on the Ribbon. 

3. Click the button for the type of Sparkline you want to use from the Sparkline’s group 

e.g., Line 

4. Select the range of cells containing the data you want to chart. 

 

5. Click Ok. 
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Printing 

32. Print your Headers on Every Page 

When you print an Excel Table that spans multiple pages, your headers will only print on 

page 1. To repeat your headers on every page you need to use a feature called Print Titles. 

1. Click the Page Layout tab on the Ribbon. 

2. Click the Print Titles button in the Page Setup group. 

3. Click in the Rows to repeat at top: box and select the row headers for the rows you 

want to print on every page. 

The image below shows the first three rows on a spreadsheet to be repeated. 

 

4. Click OK. 
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33. Print Selection Only 

By default, Excel will print the current worksheet when the print button is clicked. 

However, at times you may wish to print only a specific range on the sheet. This can be 

specified for future use by setting a Print Area. 

However, you can print a selection of a sheet quickly without the need to set up the print 

area.  This works great for ad hoc print requirements. 

1. Select the range on the sheet that you want to print. 

2. Click File > Print. 

3. Select Print Selection from the appropriate option in the Settings list. 

4. Click Print. 
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34. Print to One Page 

When printing a large spreadsheet, trying to fit it onto as few pages as possible and making 

it look professional can be an exhausting task.  One of the key features to aid you with this 

work is Excel’s scaling tool. 

You can scale a print to a specific percentage such as 80% of its normal size or fit it to a 

certain number of pages. Scaling only affects the print of the spreadsheet and not how it 

looks on screen. 

The scaling options can be found on the Page Layout tab of the Ribbon. 

 

Because these options only affect the print of a spreadsheet, I tend to use the settings in the 

Page Setup dialog box, which is accessible by clicking the Dialog Box Launcher arrow 

button in the corner of the group.  

Using this dialog box allows easy switching from Page Setup to Print Preview and vice versa 

to see how it looks. 

The ‘Fit to’ option is great for specifying exactly how many pages wide and tall the print 

should be. This makes it fast and easy to specify a print to one page only. 
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35. Hide the Gridlines on a Sheet 

Although gridlines are important for you to identify the location and boundaries of the cells on 

a sheet, it is popular to remove them for a cleaner look on reports and dashboards. 

Hiding gridlines in not really a print setting, but it is closely related enough for me to include 

in this section. 

1. Click the View tab on the Ribbon. 

2. Uncheck the Gridlines box in the Show group. 

 

The following image shows a range with the gridlines removed. Borders and fill colour are 

applied to the headers to identify them clearly. 
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Using Charts 

36. Build a Chart 

Learn to create charts in Excel to visually present your data.  Remember a ‘picture tells a 

thousand words’.  It is much easier to see comparisons, progress, trends, and relationships 

in data when displayed using a chart. 

Excel provides many charts which can be created at the click of a button. 

1. Select the data you want to use for the chart (ensure your headings are also 

selected). 

2. Click the Insert tab on the Ribbon. 

3. Click the button for the chart you would like to use in the Charts group. There is also 

a Recommended Charts button to assist you in choosing the best chart for your 

goal. 

4. Select the sub-type of the chart you want from the list (the image below shows the list 

of column and bar charts). 

 

5. The chart appears on the sheet.  The chart can now be formatted, resized, moved, 

and have labels added to it. 
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37. Create Effective Chart Titles 

When you first create a chart, the chart title will be automatically generated. This means it 

will either have a very basic and useless title, or maybe just the words ‘Chart Title’. Either 

way, please change this. 

You can improve a chart title by simply clicking on it and typing something better. 

But you can take things further. Why not use a formula to calculate a metric or other useful 

information. Then use this in your chart title for a dynamic and effective title that truly 

benefits its readers. 

You cannot type functions directly into chart titles, so typically one would write the formula in 

a cell, then link the chart title to the cell. 

In the following example, cell G2 contains a formula that sums the values of a column. The 

TEXT function formats this result in dollars and some text is concatenated. 

 

To link the chart title to cell G2: Click on the chart title, then click in the Formula bar, type “=”, 

click cell G2, and then press Enter. 

This process is precise. Charts like things in a very specific way. In this instance, you must 

type the “=” in the Formula bar and not in the chart title directly.  
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38. Apply Data Labels to a Chart 

Data Labels can be added to a chart to add more detail such as to show the values, 

percentages, or labels of the data series. 

Data Labels are often added to supplement or even replace the y-axis. 

The image below shows data labels being added above the columns (default position known 

as Outside End) as an alternative to the y-axis (the vertical axis with values). 

They have been added by checking the Data Labels box from the Chart Elements button 

(+ icon). 

 

You can use the values from any range for data labels in a chart. You are not restricted to 

the values being plotted by the data series. 

To do this: 

1. Click the Chart Elements button, the arrow to the right of Data Labels, and then 

More Options. 

2. Check the Value From Cells box and select the range of cells containing the values 

that you want to use (image below). Click OK. 

3. Uncheck the Value box. 
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In the following chart, data labels are used to display the percentage variance compared to 

sales in the previous month. A symbol is also shown to visualise this change. 
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39. Add a Secondary Axis 

Add a secondary axis to a chart when you need different data types, or values that are very 

different to each other, to co-exist on the same chart. 

In the example below the chart shows exam grades by percentage in the first axis and 

attendance figures by number in the second axis.  A secondary axis is required as you could 

not present values going from 0.1 to 1.0, and values from 150 to 250 on one axis. 

 

1. Right click on the data series you want to scale on the secondary axis and select 

Change Series Chart Type. 

2. At the bottom of the Change Chart Type window, specify the chart type for this data 

series. In this example, it is line (as shown in the following image) and check the box 

for Secondary Axis. 

3. Click OK. 
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40. Save the Chart as a Template 

This is one of the best chart tips available. 

Saving a chart template will save all the formatting and layout changes that you made, 

making future chart creation or changes super-fast and simple.  

To save a chart template: 

1. Right-click on the chart and click Save as Template. 

2. You will be taken to the chart templates folder in your directories and encouraged to 

save it there. Enter a name for your template and click Save. 

Then when inserting a new chart: 

1. Navigate to the Templates folder in the All Charts tab of the window. 

2. Select the template to use and click OK. 

 

The chart will have all the formatting and layout settings as specified in advance.  


